السلام عليكم

شرح جعل برمجياتك تعمل على اصدار php محدد

هذا الشرح مفيد في حالات كثيرة

منها أولا قد يصدر اصدار PHP ويحتوي على تغيرات كثيرة بحيث لا يعمل السكربت بشكل جيد


نقره لتكبير أو تصغير الصورة ونقرتين لعرض الصورة في صفحة مستقلة بحجمها الطبيعي

أو ربما تعلمت على اصدارات PHP قديمة وبرمجياتك لا تعمل على الاصدارات الجديدة

المهم ندخل في الشرح وشرحنا هو عن الدالة :


كود PHP:
                        phpversion() 




الآن انت تريد أن يعمل السكربت على اصدار 4.4.4 فقط مثلاً .. قم بوضع الكود التالي :


كود PHP:
 if ( '4.4.4' != phpversion() )
{
    die(
'السكربت لا يعمل على هذا الموقع');



مع تغيير 4.4.4 إلى الاصدار المطلوب

طبعا البعض يريد عمل السكربت على 4.4.4 وأعلى

يعني 4.4.4 و 4.4.5 .. الخ

لعمل ذلك قم بوضع الكود التالي :


كود PHP:
if ( '4.4.4' >= phpversion() )
{
 echo 
'السكربت يعمل بشكل جيد';
}else{
    die(
'السكربت لا يعمل على هذا الموقع');




أتمنى أن يكون الشرح مفهوم
وأي سؤال أنا حاضر